Jump to content

Issues with Updating Adress


Recommended Posts

The change of address form seems to be broken. I put in my old address and it takes me here to update my past addresses. The checkbox isn't actually selectable, and the country and state dropdowns contain no entries and I can't just type something in. This doesn't work even after adding a new address record. I've tried Firefox, Chrome, and IE.

 

I've tried to call the FOID number 3 times now, but I get off work right near when it closes. I did manage to get a call in at 2:30pm yesterday, but it still went through the same "we are experiencing high call volume" spiel. Anyone have any ideas?

post-17322-0-83340400-1479429095_thumb.png

Link to comment
Share on other sites

I could be far off.

Let me ask, are you changing your permanent address on your FOID?

If so, be sure to uncheck "Maing Address" box.

It may think your mailing address is same as your current address.

And last, be sure to change the drivers Lic address first, let it update.

I think a few others have had this issue.

 

And, Welcome to the forums.

Link to comment
Share on other sites

Thanks.

 

That's the issue, the checkbox doesn't actually work. I can't click it in any of the three browsers. This is the second part, after doing the first change of address section.

 

Edit: Ok I figured it out. On the first page, I had to not select "same as mailing address", then reenter the exact same information as current residence address. Dunno why but doubling up the information worked.

Edited by Doogie_
Link to comment
Share on other sites

  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...