Jump to content


Photo

My license was in my mail today!


  • Please log in to reply
3128 replies to this topic

#3121 Merlin&Mabel

  • Members
  • 3 posts
  • Joined: 17-October 19

Posted 25 October 2019 - 08:45 AM

Submitted 7/26/19 with Fingerprints
QC_Verified 10/17/19 (Day 83)
Approved 10/21/19 (Day 87)
Active 10/22/19 (Day 88)
In hand from mailbox 5 minutes ago 10/25/19 (Day 91)

Overall, not the longest or shortest wait. Pretty surprised the state stuck to the 90 day response time.

#3122 Rem870

    Member

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 506 posts
  • Joined: 26-January 08

Posted 27 October 2019 - 10:21 AM

Renewal finally went active after 8 months. Denied at 4 months to the day from renewal application due to the training certificate having the trainers ID number incorrect (pre-printed from trainer). Fixed and resubmitted and after another 4 months to the day it finally went active. I guess on the bright side I added 8 months to my ccl.

Since it’s always takes exactly the allowed number of days, I believe they do it just because they can.

#3123 r.obb

  • Members
  • 23 posts
  • Joined: 12-October 05

Posted 30 October 2019 - 08:12 PM

I applied on 9-5-19 for a replacement FOID and CCL due to them being destroyed. My dog ate my wallet. Any guesses on the wait time? I submitted prints with original submission..... 



#3124 Tean0

  • Members
  • 4 posts
  • Joined: 15-July 19

Posted 12 November 2019 - 09:27 PM

CCL app was rejected due to DL address not matching what was submitted with the application. The only thing that was missing when prompted to resubmit was the APT 1 portion of the address. I had originally entered it when first applying however it did not reflect on the website. I was on day 127 with no prints. Anything I can do to fight it or am I stuck waiting 120 days again?


In the past, a correction like this would not take the whole 120 days. Not sure how long it will take with this new administration... It will be interesting to see, please keep us posted.


#3125 Tean0

  • Members
  • 4 posts
  • Joined: 15-July 19

Posted 12 November 2019 - 09:29 PM

CCL app was rejected due to DL address not matching what was submitted with the application. The only thing that was missing when prompted to resubmit was the APT 1 portion of the address. I had originally entered it when first applying however it did not reflect on the website. I was on day 127 with no prints. Anything I can do to fight it or am I stuck waiting 120 days again?

In the past, a correction like this would not take the whole 120 days. Not sure how long it will take with this new administration... It will be interesting to see, please keep us posted.

Showed approved with inspect element on 11/8
Active on 11/11
Wait begins after almost 225 days

#3126 bigbob

    Member

  • Members
  • PipPip
  • 113 posts
  • Joined: 05-August 12

Posted 17 November 2019 - 07:18 AM

Glad you finally were able to get things straightened out.



#3127 Pacemaker

  • Supporting Members Team
  • 2 posts
  • Joined: 24-August 19

Posted 17 November 2019 - 02:58 PM

Hi everyone, this is my first post.

 

I applied for ccl w/finger prints on 8-16-2019

 

Just prior to 90 days I started to login on ISP everyday from 11-11 to 11-15, it just showed, inactive review pending. On Friday there was no change, so I figure no one will be processing on the weekend and I'll start looking on Monday again.

 

I was messing around on the computer today (Sunday), and login to ISP and there is was, to my surprise, they activated my CCL on Saturday 11-16-2019.  That would make it 92 day, I guess I should see my card in my mailbox by the end of the week.



#3128 Pacemaker

  • Supporting Members Team
  • 2 posts
  • Joined: 24-August 19

Posted 20 November 2019 - 05:20 PM

Hi everyone, this is my first post.

 

I applied for ccl w/finger prints on 8-16-2019

 

Just prior to 90 days I started to login on ISP everyday from 11-11 to 11-15, it just showed, inactive review pending. On Friday there was no change, so I figure no one will be processing on the weekend and I'll start looking on Monday again.

 

I was messing around on the computer today (Sunday), and login to ISP and there is was, to my surprise, they activated my CCL on Saturday 11-16-2019.  That would make it 92 day, I guess I should see my card in my mailbox by the end of the week.

Received CCL today, ISP postmarked on 11-18. took three days. 



#3129 pigfinn

  • Members
  • 7 posts
  • Joined: 21-September 19

Posted 20 November 2019 - 11:21 PM

 

Hi everyone, this is my first post.

 

I applied for ccl w/finger prints on 8-16-2019

 

Just prior to 90 days I started to login on ISP everyday from 11-11 to 11-15, it just showed, inactive review pending. On Friday there was no change, so I figure no one will be processing on the weekend and I'll start looking on Monday again.

 

I was messing around on the computer today (Sunday), and login to ISP and there is was, to my surprise, they activated my CCL on Saturday 11-16-2019.  That would make it 92 day, I guess I should see my card in my mailbox by the end of the week.

Received CCL today, ISP postmarked on 11-18. took three days. 

 

 

I applied in March 2019.  I had to resend a new photo in July.  I have received nothing yet.  Given your stats, I'm guessing mine is lost MIA forever.






2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users